[jira] [Created] (XMLBEANS-553) xmlbeans 4.0.0 generated code from xsd incompatible with xmlbeans 4.0.0

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Created] (XMLBEANS-553) xmlbeans 4.0.0 generated code from xsd incompatible with xmlbeans 4.0.0

PJ Fanning (Jira)
Ward Maenhout created XMLBEANS-553:
--------------------------------------

             Summary: xmlbeans 4.0.0 generated code from xsd incompatible with xmlbeans 4.0.0
                 Key: XMLBEANS-553
                 URL: https://issues.apache.org/jira/browse/XMLBEANS-553
             Project: XMLBeans
          Issue Type: Bug
          Components: Compiler
    Affects Versions: Version 4.0.0
            Reporter: Ward Maenhout
         Attachments: xmlbeans-broken.zip

When trying to update our project to xmlbeans 4.0.0, we discovered xmlbeans generates invalid source code.

The generated code contains references to org.apache.xmlbeans.xml.stream.XMLInputStream which was deleted in xmlbeans 4.0.0

Attached a simple maven project to simulate the situation. Using xmlbeans 3.1.0, there is no issue, updating to 4.0.0 and you have the problem.

 



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]