[jira] [Commented] (XMLBEANS-560) Pluggable XPath/XQuery engine support removed

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (XMLBEANS-560) Pluggable XPath/XQuery engine support removed

PJ Fanning (Jira)

    [ https://issues.apache.org/jira/browse/XMLBEANS-560?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17316872#comment-17316872 ]

Andreas Beeker commented on XMLBEANS-560:
-----------------------------------------

http://apache-poi.1045710.n5.nabble.com/Missing-binding-classes-for-commercial-XQuery-libraries-td5735820.html

This has been removed as part of the above decision. If you plan to provide a patch, this probably should go along a JPMS service loader implementation and be compatible with OSGi.


> Pluggable XPath/XQuery engine support removed
> ---------------------------------------------
>
>                 Key: XMLBEANS-560
>                 URL: https://issues.apache.org/jira/browse/XMLBEANS-560
>             Project: XMLBeans
>          Issue Type: Bug
>          Components: XPath
>    Affects Versions: Version 5.0.0
>            Reporter: Dimitrios Lagkouvardos
>            Priority: Major
>
> XMLBEANS-373 introduced pluggable XPath engine support, which we have been using for years. It looks like 5.0.0 removed that. This is blocking our upgrade to 5.0.0.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]