[jira] [Commented] (XMLBEANS-536) Increase Java 9+ compatibility

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (XMLBEANS-536) Increase Java 9+ compatibility

Andreas Beeker (Jira)

    [ https://issues.apache.org/jira/browse/XMLBEANS-536?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17143315#comment-17143315 ]

Andreas Beeker commented on XMLBEANS-536:
-----------------------------------------

use TypeSystemHolder directly instead of ClassLoader reflection - via r1879130

> Increase Java 9+ compatibility
> ------------------------------
>
>                 Key: XMLBEANS-536
>                 URL: https://issues.apache.org/jira/browse/XMLBEANS-536
>             Project: XMLBeans
>          Issue Type: Bug
>          Components: DOM, SOM, XmlObject
>    Affects Versions: Version 3.0.2
>            Reporter: Andreas Beeker
>            Priority: Major
>             Fix For: Version 4.0.0
>
>          Time Spent: 20m
>  Remaining Estimate: 0h
>
> This ticket documents several steps to increase Java 9+ compatibility.
> The goal is to be backward compatible, but eventually allow XmlBeans to be used within Jigsaw and to take into account the changes around the XML modules with each JDK version.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]