[jira] [Comment Edited] (XMLBEANS-553) xmlbeans 4.0.0 generated code from xsd incompatible with xmlbeans 4.0.0

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Comment Edited] (XMLBEANS-553) xmlbeans 4.0.0 generated code from xsd incompatible with xmlbeans 4.0.0

PJ Fanning (Jira)

    [ https://issues.apache.org/jira/browse/XMLBEANS-553?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17278971#comment-17278971 ]

PJ Fanning edited comment on XMLBEANS-553 at 2/4/21, 4:54 PM:
--------------------------------------------------------------

[~wma] are you sure that you didn't generate the code with xmlbeans 3.1.0 (or older) and they try to compile or run with xmlbeans 4.0.0?

The Apache POI project uses xmlbeans to generate the code with xmlbeans 4.0.0 and compiles and runs with xmlbeans 4.0.0 and there are no issues.

The XMLInputStream based methods do not appear in Apache POI generated source.


was (Author: pj.fanning):
[~wma] are you sure that you didn't generate the code with xmlbeans 3.1.0 (or older) and they try to compile or run with xmlbeans 4.0.0?

The Apache POI project uses xmlbeans to generate the code with xmlbeans 4.0.0 and compiles and runs with xmlbeans 4.0.0 and there are no issues.

The XMLInputStream based methods so not appear in Apache POI generated source.

> xmlbeans 4.0.0 generated code from xsd incompatible with xmlbeans 4.0.0
> -----------------------------------------------------------------------
>
>                 Key: XMLBEANS-553
>                 URL: https://issues.apache.org/jira/browse/XMLBEANS-553
>             Project: XMLBeans
>          Issue Type: Bug
>          Components: Compiler
>    Affects Versions: Version 4.0.0
>            Reporter: wma
>            Priority: Critical
>              Labels: code-generation
>         Attachments: xmlbeans-broken.zip
>
>
> When trying to update our project to xmlbeans 4.0.0, we discovered xmlbeans generates invalid source code.
> The generated code contains references to org.apache.xmlbeans.xml.stream.XMLInputStream which was deleted in xmlbeans 4.0.0
> Attached a simple maven project to simulate the situation. Using xmlbeans 3.1.0, there is no issue, updating to 4.0.0 and you have the problem.
>  
> {quote}error: cannot find symbol
>  public static org.broken.xmlbeans.xmlBeansBrokenSchema.xmlbeans.XmlBean parse(org.apache.xmlbeans.xml.stream.XMLInputStream xis, org.apache.xmlbeans.XmlOptions options) throws org.apache.xmlbeans.XmlException, org.apache.xmlbeans.xml.stream.XMLStreamException {
>  ^
>  symbol: class XMLStreamException
>  location: package org.apache.xmlbeans.xml.stream
> {quote}
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]