java.lang.ClassCastException: com.ibm.xml.xlxp2.api.stax.XMLEventFactoryImpl incompatible with javax.xml.stream.XMLEventFactory

2 messages Options
java.lang.ClassCastException: com.ibm.xml.xlxp2.api.stax.XMLEventFactoryImpl incompatible with javax.xml.stream.XMLEventFactory – I am attempting to upgrade my project to Spring 5 running on Websphere 8.5. We are using the IBM JDK 1.8_64. I'm running into an issue readin...
It looks like that IBM pull parser is incompatible with what POI needs. Could you try adding https://github.com/FasterXML/woodstox to your classp...