getCellType() always returns 0 (Numeric)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

getCellType() always returns 0 (Numeric)

elgreenro
Hello dear community!

I have a problem. When I read an xls file with apache POI, I always recive
from  getCellType() the value 0. That is incorrect. I have other types of
data inserted in sheet. And I don't really understand why this is happening.

This is what my logger say everytime it parse a cell. Like everytime.
Type = 0

Does anyone know or have a clue why is this happening?

Thx





--
Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: getCellType() always returns 0 (Numeric)

Dominik Stadler
Hi,

can you share a sample file and some more code-snippet how you try to load
and access the file?

Dominik.


On Fri, Mar 27, 2020 at 5:32 PM elgreenro <[hidden email]> wrote:

> Hello dear community!
>
> I have a problem. When I read an xls file with apache POI, I always recive
> from  getCellType() the value 0. That is incorrect. I have other types of
> data inserted in sheet. And I don't really understand why this is
> happening.
>
> This is what my logger say everytime it parse a cell. Like everytime.
> Type = 0
>
> Does anyone know or have a clue why is this happening?
>
> Thx
>
>
>
>
>
> --
> Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>