Re: Build failures

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Build failures

Dominik Stadler
Hi,

FYI, I had strange problems with building the latest trunk, "junit doesn't
support the nested "modulepath" element.", I finally found out why my build
failed with this error, it is caused by having some outdated jar-files
located in "~/.ant/lib", which I had in place for years so completely
forgot about.

If you should run into this you can either remove the jar-files there or
use the Ant-option "-nouserlib Run ant without using the jar files from
${user.home}/.ant/lib" when starting the build.

Regards... Dominik.


On Wed, Jul 29, 2020 at 9:40 AM PJ Fanning <[hidden email]> wrote:

> Hi Dominik,
> I can't see any specific but I would suggest that you install the latest
> ant release to see if that helps.
>
> Regards,
> PJ
>
>
>
>
> On Wednesday 29 July 2020, 07:19:39 GMT+2, Dominik Stadler <
> [hidden email]> wrote:
>
>
>
>
>
> Hi,
>
> When I try to compile the latest trunk I have a strange local failure
> which I cannot explain, "modulepath" should be available at this point
> according to the documentation, looks a bit like some jar-file mixup, but
> could not find out:
>
> Any hint appreciated!
>
> Dominik.
>
>
> init:
>      [echo] Using Ant: Apache Ant(TM) version 1.10.5 compiled on March 28
> 2019 from /usr/share/ant, Ant detected Java 1.8 (may be different than
> actual Java sometimes...)
>      [echo] Using Java:
> 1.8.0_252/1.8.0_252-8u252-b09-1~18.04-b09/25.252-b09/OpenJDK 64-Bit Server
> VM from Private Build on Linux: 4.15.0-106-generic
>      [echo] Building Apache POI version 5.0.0-SNAPSHOT and RC: RC1
>
> -version-java-check:
>
> compile-version:
>      [copy] Copying 1 file to
> /opt/apache/poi/trunk/build/classes/org/apache/poi
>     [javac] Compiling 1 source file to /opt/apache/poi/trunk/build/classes
>    [delete] Deleting:
> /opt/apache/poi/trunk/build/classes/org/apache/poi/Version.java
>
> compile-main:
>       [jar] Building jar:
> /opt/apache/poi/trunk/build/dist/maven/poi/poi-5.0.0-SNAPSHOT.jar
>       [jar] Building jar:
> /opt/apache/poi/trunk/build/dist/maven/poi-tests/poi-5.0.0-SNAPSHOT-tests.jar
>
> -test-main-check:
>
> jacocotask:
>      [echo] Coverage reporting: ${coverage.enabled}
>
> test-main:
>
> BUILD FAILED
> /opt/apache/poi/trunk/build.xml:1393: The following error occurred while
> executing this line:
> /opt/apache/poi/trunk/build.xml:1112: junit doesn't support the nested
> "modulepath" element.
>
> On Sun, Jul 26, 2020 at 12:09 AM PJ Fanning <[hidden email]> wrote:
> > Probably no urgency on fixing the builds.
> >
> > The JDK 1.8 build just passed but other builds are failing - every build
> seems to have its own problem.
> >
> > On my laptop, many other tests fail when I use ant build. I've been
> using gradle or taking pot-luck and depending on the jenkins builds.
> >
> > It would be good if the jenkins builds recorded the test xml/txt files
> to allow for easier debugging.
> >
> >
> >
> >
> >
> > On Saturday 25 July 2020, 23:03:52 GMT+2, Andreas Beeker <
> [hidden email]> wrote:
> >
> >
> >
> >
> >
> > Hi PJ and Dominik,
> >
> > I'm now one week in Laragne-Monteglin and left my expensive gear back
> home.
> > I'll have a look at the remaining build problems, when I'll be back home
> again.
> >
> > I had a short look at the signature failure, but didn't find a clue why
> it's happening so late in the build, when it's successful before. The
> difference to the previous build is, that the tests aren't split anymore.
> > So maybe some setting gets overridden.
> >
> > I'll regularly check my emails in case you have question on the last
> build changes.
> >
> > Best wishes
> > Andi
> >
> > --
> > Sent from my phone - please excuse my brevity.
> >
> >
>