Java-11 Compatibility of POI 4.0.x

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Java-11 Compatibility of POI 4.0.x

kjilla
We see that java-11 no longer supports property "java.version". Does the
latest poi 4.0.x support java-11 since it has traces of java.version in it?
What is the versions that would be compatible and Supported with Java-11?

Can i know Date at which the supported library is planned to be available.




--
Sent from: http://apache-poi.1045710.n5.nabble.com/POI-Dev-f2312866.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Java-11 Compatibility of POI 4.0.x

pj.fanning
We unit test our POI 4.0 code base with java 11.

if you are seeing issues, could you provide a lot more detail?



--
Sent from: http://apache-poi.1045710.n5.nabble.com/POI-Dev-f2312866.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Java-11 Compatibility of POI 4.0.x

Dominik Stadler
Hi,

we verify Java 11 as part of our CI, I have now updated our related FAQ
entry at http://poi.apache.org/help/faq.html#faq-N102B0 to reflect the
current state.

As far as I see, the system property java.version is still supported, e.g.
our CI build for Java 11 prints out the following when we access
java.version in our Ant based build: "[echo] Using Java:
11.0.1/11.0.1+13-LTS/11.0.1+13-LTS/Java HotSpot(TM) 64-Bit Server VM from
Oracle Corporation on Linux: 4.4.0-138-generic", see
https://builds.apache.org/view/P/view/POI/job/POI-DSL-1.11/24/console , why
do you think it is not available any more?

Please report bugs for any additional problem that you might stumble upon.

Thanks... Dominik.

On Thu, Jan 10, 2019 at 2:42 PM pj.fanning <[hidden email]> wrote:

> We unit test our POI 4.0 code base with java 11.
>
> if you are seeing issues, could you provide a lot more detail?
>
>
>
> --
> Sent from: http://apache-poi.1045710.n5.nabble.com/POI-Dev-f2312866.html
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>