I tey to get POI 4.1.0 to work in Atlassian Confleuce 7.0.0 or above

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

I tey to get POI 4.1.0 to work in Atlassian Confleuce 7.0.0 or above

walkout_
Hi,

I try to get POI 4.1.0 to work in Atlassian Confleuce 7.0.0 or above.

I get these error massages:





Atlassian Confleuce already includes a xerces but version
xercesImpl-2.12.0.jar.

Does anyone haves idea what is wrong?



--
Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: I tey to get POI 4.1.0 to work in Atlassian Confleuce 7.0.0 or above

walkout_
I do not need help anymore.

This line was missing from the pom.xml.

<dependency>
    <groupId>org.apache.santuario</groupId>
    <artifactId>xmlsec</artifactId>
    <version>2.1.2</version>
    <scope>compile</scope>
</dependency>



--
Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: I tey to get POI 4.1.0 to work in Atlassian Confleuce 7.0.0 or above

pj.fanning
Anyone know why we omit xmlsec dependency from the poi-ooxml pom file?

https://repo.maven.apache.org/maven2/org/apache/poi/poi-ooxml/4.1.0/poi-ooxml-4.1.0.pom

If we don't want a full runtime/compile scope, could we add a
`provided`scope?



--
Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: I tey to get POI 4.1.0 to work in Atlassian Confleuce 7.0.0 or above

walkout_
If you do not use Atlassian Confluence then you do not need to use compile
scope.

I  do not recommend to do Confluence Wiki Apps which requires the is users
to add missing dependencies to it's lib folders manually.



--
Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: I tey to get POI 4.1.0 to work in Atlassian Confleuce 7.0.0 or above

kiwiwings
In reply to this post by pj.fanning
pj.fanning wrote
> Anyone know why we omit xmlsec dependency from the poi-ooxml pom file?
>
> If we don't want a full runtime/compile scope, could we add a
> `provided`scope.

I've regarded the signing stuff as nice to have, as it is a rarely used
feature.
If we add xmlsec, also the additional bouncycastle dependencies should be
added.

I'm +0 to add the dependencies in the next release after 4.1.1

Andi



--
Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: I tey to get POI 4.1.0 to work in Atlassian Confleuce 7.0.0 or above

pj.fanning
Agreed about not delaying POI 4.1.1 release due to this discussion.



--
Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]