How To Get/Generated XmlBean

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

How To Get/Generated XmlBean

Eliot Kimber
The very latest POI code requires XmlBeans 3.0.1 which is not yet released.

How do I get or build the 3.0.1 jar?

I cloned https://github.com/apache/xmlbeans but there didn't seem to be an Ant target comparable to mvn-install as in the main POI project.

Thanks,

Eliot
--
Eliot Kimber
http://contrext.com
 



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: How To Get/Generated XmlBean

Dave Fisher-5
Hi -

A vote to release XMLBeans 3.0.1 is currently in progress on the [hidden email] mailing list. You can take a look there and download the RC.

Regards,
Dave

On Aug 20, 2018, at 8:50 AM, Eliot Kimber <[hidden email]> wrote:

The very latest POI code requires XmlBeans 3.0.1 which is not yet released.

How do I get or build the 3.0.1 jar?

I cloned https://github.com/apache/xmlbeans but there didn't seem to be an Ant target comparable to mvn-install as in the main POI project.

Thanks,

Eliot
--
Eliot Kimber
http://contrext.com




---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]



signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: How To Get/Generated XmlBean

Mark Murphy
Does it require XMLBeans 3.01, or will 2.3 still work?

On Mon, Aug 20, 2018 at 11:53 AM Dave Fisher <[hidden email]> wrote:

> Hi -
>
> A vote to release XMLBeans 3.0.1 is currently in progress on the
> [hidden email] mailing list. You can take a look there and download
> the RC.
>
> Regards,
> Dave
>
> On Aug 20, 2018, at 8:50 AM, Eliot Kimber <[hidden email]> wrote:
>
> The very latest POI code requires XmlBeans 3.0.1 which is not yet
> released.
>
> How do I get or build the 3.0.1 jar?
>
> I cloned https://github.com/apache/xmlbeans but there didn't seem to be
> an Ant target comparable to mvn-install as in the main POI project.
>
> Thanks,
>
> Eliot
> --
> Eliot Kimber
> http://contrext.com
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: How To Get/Generated XmlBean

pj.fanning
The latest poi trunk ant build will pull the xmlbeans 3.0.1 from apache
staging mvn repo.
The CI build for poi is working with this.



--
Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: How To Get/Generated XmlBean

Mark Murphy
Ok, there are two requirements here, one to build POI, and the other to run
POI. Is XMLBeans 3.0 required to both build and run POI 4.0? Or just to
Build it? Will it still run on XMLBeans 2.3 or 2.6 albeit with less
functionality? Or have we changed the runtime requirement to XMLBeans 3.01.

On Mon, Aug 20, 2018 at 2:32 PM pj.fanning <[hidden email]> wrote:

> The latest poi trunk ant build will pull the xmlbeans 3.0.1 from apache
> staging mvn repo.
> The CI build for poi is working with this.
>
>
>
> --
> Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: How To Get/Generated XmlBean

pj.fanning
POI now needs xmlbeans 3.0.1. It will only work with this version.



--
Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: How To Get/Generated XmlBean

Eliot Kimber
I must not have done the necessary clean or build. I did it again and I do have XmlBeans 3.0.1 in my local mvn repo.

Cheers,

E.

--
Eliot Kimber
http://contrext.com
 

On 8/20/18, 1:47 PM, "pj.fanning" <[hidden email]> wrote:

    POI now needs xmlbeans 3.0.1. It will only work with this version.
   
   
   
    --
    Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html
   
    ---------------------------------------------------------------------
    To unsubscribe, e-mail: [hidden email]
    For additional commands, e-mail: [hidden email]
   
   
   



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: How To Get/Generated XmlBean

Eliot Kimber
Actually, it put the jar in ooxml-lib, not in my mvn repo, but of course it's easy enough to copy.

Cheers,

E.

--
Eliot Kimber
http://contrext.com
 

On 8/20/18, 2:07 PM, "Eliot Kimber" <[hidden email]> wrote:

    I must not have done the necessary clean or build. I did it again and I do have XmlBeans 3.0.1 in my local mvn repo.
   
    Cheers,
   
    E.
   
    --
    Eliot Kimber
    http://contrext.com
     
   
    On 8/20/18, 1:47 PM, "pj.fanning" <[hidden email]> wrote:
   
        POI now needs xmlbeans 3.0.1. It will only work with this version.
       
       
       
        --
        Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html
       
        ---------------------------------------------------------------------
        To unsubscribe, e-mail: [hidden email]
        For additional commands, e-mail: [hidden email]
       
       
       
   
   
   
    ---------------------------------------------------------------------
    To unsubscribe, e-mail: [hidden email]
    For additional commands, e-mail: [hidden email]
   
   
   



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]