[Bug 63857] New: Can we upgrade ant 1.8.2 to ant-1.9.12 while using poi 4.0.1 ?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 63857] New: Can we upgrade ant 1.8.2 to ant-1.9.12 while using poi 4.0.1 ?

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63857

            Bug ID: 63857
           Summary: Can we upgrade ant 1.8.2 to ant-1.9.12 while using poi
                    4.0.1 ?
           Product: POI
           Version: 4.0.1-FINAL
          Hardware: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: POI Overall
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

hi Team,

This is more of a query. This is regarding a Security issue raised internally
in our team related to usage of ant version lower than 1.9.12 version. As we
know poi-excelant-4.0.1 is dependent on ant-1.8.2, hence, i would like to know
if we upgrade ant-1.8.2 to ant-1.9.12, is it fine ?

Could you please let us know ?

Regards,
Sushmita

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 63857] Can we upgrade ant 1.8.2 to ant-1.9.12 while using poi 4.0.1 ?

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63857

Nick Burch <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |NEEDINFO
                 OS|                            |All

--- Comment #1 from Nick Burch <[hidden email]> ---
Are you making use of the ExcelAnt integration? If not, just exclude the
poi-excelant and dependencies from your project. It isn't required for most POI
functionality, just the ant-based testing of excel file contents
<https://poi.apache.org/components/spreadsheet/excelant.html>

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 63857] Can we upgrade ant 1.8.2 to ant-1.9.12 while using poi 4.0.1 ?

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63857

Dominik Stadler <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEEDINFO                    |RESOLVED
         Resolution|---                         |WORKSFORME

--- Comment #2 from Dominik Stadler <[hidden email]> ---
You should be able to simply override the dependency on Ant if you cannot
exclude it as Nick described. We are testing with versions up to 1.10 in CI and
locally.

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]