[Bug 63675] New: Xmlbeans 3.1.0 compilation errors exist in class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllImpl and class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllNNIImpl

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 63675] New: Xmlbeans 3.1.0 compilation errors exist in class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllImpl and class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllNNIImpl

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63675

            Bug ID: 63675
           Summary: Xmlbeans 3.1.0 compilation errors exist in class
                    org.apache.xmlbeans.impl.xb.xsdschema.impl.AllImpl and
                    class
                    org.apache.xmlbeans.impl.xb.xsdschema.impl.AllNNIImpl
           Product: POI
           Version: unspecified
          Hardware: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: POI Overall
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

The class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllImpl.MaxOccursImpl does
not override the enumValue () and set () methods in the
org.apache.xmlbeans.impl.xb.xsdschema.AllNNI.Members class.The same is true in
the class AllNNIImpl....Request Solution!

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 63675] Xmlbeans 3.1.0 compilation errors exist in class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllImpl and class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllNNIImpl

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63675

Dominik Stadler <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |NEEDINFO
                 OS|                            |All

--- Comment #1 from Dominik Stadler <[hidden email]> ---
Sorry, but this way your bug-report is not very useful, without a clear way how
to reproduce we will only be able to set it to "CANNOT REPRODUCE".

How do you try to compile it? What exact steps are necessary to reproduce the
problem? ...

And is this only related to XMLBeans and not Apache POI? Then please report
this at http://issues.apache.org/jira/secure/BrowseProject.jspa?id=10436
instead.

And please remember that this is a fully community project without anybody
being paid to work on, so "requesting a solution" is not the best way to ask
for help here...

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 63675] Xmlbeans 3.1.0 compilation errors exist in class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllImpl and class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllNNIImpl

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63675

--- Comment #2 from xiao yuan <[hidden email]> ---
(In reply to Dominik Stadler from comment #1)

> Sorry, but this way your bug-report is not very useful, without a clear way
> how to reproduce we will only be able to set it to "CANNOT REPRODUCE".
>
> How do you try to compile it? What exact steps are necessary to reproduce
> the problem? ...
>
> And is this only related to XMLBeans and not Apache POI? Then please report
> this at http://issues.apache.org/jira/secure/BrowseProject.jspa?id=10436
> instead.
>
> And please remember that this is a fully community project without anybody
> being paid to work on, so "requesting a solution" is not the best way to ask
> for help here...

Yes,I'm trying to compile XMLBeans and moving Apache POI to Android OS.When I
optimized the source code(XMLBeans), Android studio reported errors.The same
problem has also been found in many classes under package
org.apache.xmlbeans.impl.xb.xsdschema.impl*.

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 63675] Xmlbeans 3.1.0 compilation errors exist in class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllImpl and class org.apache.xmlbeans.impl.xb.xsdschema.impl.AllNNIImpl

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=63675

xiao yuan <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|---                         |INVALID
             Status|NEEDINFO                    |RESOLVED

--- Comment #3 from xiao yuan <[hidden email]> ---
I'm sorry!That was my mistake.I deleted the method marked as deprecated in the
base class org.apache.xmlbeans.impl.values.XmlObjectBase, while the
corresponding methods in some interfaces were not marked deprecated.

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]