[Bug 62815] New: Incorrect "0" value for largish integers in xlsb files

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 62815] New: Incorrect "0" value for largish integers in xlsb files

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=62815

            Bug ID: 62815
           Summary: Incorrect "0" value for largish integers in xlsb files
           Product: POI
           Version: unspecified
          Hardware: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: XSSF
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

Created attachment 36194
  --> https://bz.apache.org/bugzilla/attachment.cgi?id=36194&action=edit
triggering document

On the user list, Dejan Ikodinovic noted that some large integer values are
incorrectly extracted as "0" in xlsb.

I can reproduce this with the attached file, which, in Tika, yields:

<table><tbody><tr>      <td>1880000</td>        <td>10000000</td></tr>
<tr>    <td>0</td></tr>
<tr>    <td>0</td></tr>
<tr>    <td>0</td></tr>
<tr>    <td>1880004</td></tr>
<tr>    <td>0</td></tr>
<tr>    <td>0</td></tr>
<tr>    <td>0</td></tr>
<tr>    <td>1880008</td></tr>
<tr>    <td>0</td></tr>
<tr>    <td>0</td></tr>
<tr>    <td>0</td></tr>
<tr>    <td>1880012</td></tr>

I haven't figured out what the cause of this is.  It is possible that the
problem is at the Tika level, but my guess is that I botched something at the
POI level.

As a side note, if I save the file as xlsx, the numbers are extracted
correctly.

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 62815] Incorrect "0" value for largish integers in xlsb files

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=62815

Tim Allison <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|---                         |FIXED
             Status|NEW                         |RESOLVED
                 OS|                            |All

--- Comment #1 from Tim Allison <[hidden email]> ---
r1843553

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]