[Bug 61988] New: POI depends on Apache xmlbeans which has been EOL since 2014

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 61988] New: POI depends on Apache xmlbeans which has been EOL since 2014

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61988

            Bug ID: 61988
           Summary: POI depends on Apache xmlbeans which has been EOL
                    since 2014
           Product: POI
           Version: 3.17-FINAL
          Hardware: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: POI Overall
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

POI is dependent upon xmlbeans-2.6.0 which has been retired since 2014.

Also, the xmlbeans-2.6.0.jar contains two copies of class
org.apache.xmlbeans.xml.stream.Location, which causes jarsigner to fail.

Somebody should either fix xmlbeans or move POI to use Apache Attic, as
advertised.

Thanks,
David

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 61988] POI depends on Apache xmlbeans which has been EOL since 2014

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61988

Nick Burch <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 OS|                            |All
             Status|NEW                         |RESOLVED
         Resolution|---                         |MOVED

--- Comment #1 from Nick Burch <[hidden email]> ---
Please see threads on the POI dev list such as
https://lists.apache.org/thread.html/8ad08d39e616e5a48cfbf1b12385711474dd3153e5ad650174f682d3@%3Cdev.poi.apache.org%3E
and
http://apache-poi.1045710.n5.nabble.com/DISCUSS-Getting-a-fixed-version-of-XMLBeans-td5729378.html
for discussions on the fix for this in Apache POI 4.0

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 61988] POI depends on Apache xmlbeans which has been EOL since 2014

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61988

Dominik Stadler <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|MOVED                       |DUPLICATE

--- Comment #2 from Dominik Stadler <[hidden email]> ---
Also bug 59268 handles this in bugzilla.

*** This bug has been marked as a duplicate of bug 59268 ***

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]