[Bug 61490] New: In a particular document, the cell is missing

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Bug 61490] New: In a particular document, the cell is missing

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61490

            Bug ID: 61490
           Summary: In a particular document, the cell is missing
           Product: POI
           Version: 3.16-FINAL
          Hardware: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: HWPF
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

Created attachment 35292
  --> https://bz.apache.org/bugzilla/attachment.cgi?id=35292&action=edit
the test code and .doc file

Sorry for my poor english
I'm using Google Translate

I uploaded my test code and test files, see attachment

In this particular case of attachment

   table.numRows() return  4  (actually, it should be 3)

  and the  row.numCells()  at row[2] ,return 2

  so, the last cell of table (cell value is  33) is missing

But,
  if you insert a space or whatever character before the last cell of table ,
  then correct !

I tested 3.16 and 3.17-beta1, same results

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 61490] In a particular document, the cell is missing

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61490

Tim Allison <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 OS|                            |All

--- Comment #1 from Tim Allison <[hidden email]> ---
This _may_ be related to: https://issues.apache.org/jira/browse/TIKA-1194

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Bug 61490] In a particular document, the cell is missing

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61490

Dominik Stadler <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|---                         |FIXED

--- Comment #2 from Dominik Stadler <[hidden email]> ---
This should be fixed via r1866055 in trunk now, it seems Word has some "fake"
cell at the end of tables, but this document does not have one.

However at least LibreOffice "corrects" this when the document is saved after
any change, but the original document still failed to find this cell, so we now
better check if the last cell should be excluded or not.

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]