[Bug 61272] New: In style.xml is inserted the tag <border/> without attributes

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 61272] New: In style.xml is inserted the tag <border/> without attributes

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61272

            Bug ID: 61272
           Summary: In style.xml is inserted the tag <border/> without
                    attributes
           Product: POI
           Version: 3.14-FINAL
          Hardware: PC
                OS: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: XSSF
          Assignee: [hidden email]
          Reporter: [hidden email]
  Target Milestone: ---

Sometimes inserting a new cell border, the final xlsx file has the related
style.xml which contains the tag <border/> without additional attributes; this
behavior causes problems when the xlsx file is subsequently processed.
Do you know if the insertion of the empty <border/> tag is correct ?

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 61272] In style.xml is inserted the tag <border/> without attributes

Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61272

--- Comment #1 from PJ Fanning <[hidden email]> ---
Can you provide the following?
* poi version
* unit test or sample code
* a description of what happens when you try to read the xlsx file

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 61272] In style.xml is inserted the tag <border/> without attributes

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61272

--- Comment #2 from Greg Woolsey <[hidden email]> ---
All sub-elements of the cell border are optional in the ECMA OOXML spec, so an
empty tag is allowed.

It is also allowed to be missing entirely.

In POI the class XSSFCellStyle handles undefined and defaulted/empty border
definitions properly.  What problem are you having specifically?

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 61272] In style.xml is inserted the tag <border/> without attributes

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61272

Greg Woolsey <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |NEEDINFO

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 61272] In style.xml is inserted the tag <border/> without attributes

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61272

duffy duck <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEEDINFO                    |RESOLVED
         Resolution|---                         |FIXED

--- Comment #3 from duffy duck <[hidden email]> ---
If ECMA OOXML spec allows this behavior then we will try to solve our problem
on the SW which access the excel file.
Thanks

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Bug 61272] In style.xml is inserted the tag <border/> without attributes

Bugzilla from bugzilla@apache.org
In reply to this post by Bugzilla from bugzilla@apache.org
https://bz.apache.org/bugzilla/show_bug.cgi?id=61272

Javen O'Neal <[hidden email]> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|FIXED                       |WONTFIX

--- Comment #4 from Javen O'Neal <[hidden email]> ---
Since no action was taken, changing this to WON'T FIX.

--
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...